App crashes on Android and iOS


#1

My IKAWA home roaster arrived this weekend and I’m just getting started… but the app seems fairly unstable. I’ve had it crash when loading the roast profile for Etheopian coffee that came with the roaster, and again when editing the default profile for the Colombian coffee

These crashes are reproducible on both iOS and Android.

For a device that is completely dependent on the app to function, this seems like a major problem.

I’m surprised no one else has reported this on these forums. Is it just me, or is anyone else having problems with the app?


Fan issue after firmware update
#2

I’ve not have any problems like that on Android in the 11 months I’ve been using it. The app has crashed a couple of times when I’ve had lots of other apps open on my phone while roasting but never whilst editing a profile or sending a profile to the roaster.

If it was a common problem you can be sure someone on here would have brought it up before now.

Possibly best to contact Ikawa directly as they are less than active on the forum in recent times.

Hope you get it sorted asap.


#3

I agree with what Stephan said. For me I don’t think the app has crashed. The only glitch in the all has been a lag that happens when switching between stuff (different apps or profiles) and there is a delay to loading the profile that is currently being roasted. And the “share/don’t share” asks me multiple times but besides that no crashes, that I can think of.


#4

Just to echo the other replies. I have been using the Home Roaster app with IoS devices since I bought the machine, about a year ago. I’ve never had a crash.


#6

Unfortunately, it crashes for me all the time I tried using a personalised profile. Whenever is a profile I download from Ikawa or one that I create myself, it crashes the app.

I noticed that downloaded profiles or modified by me appear with a black circle while the original profiles have a red circle.

I tried while coneected to the roaster and without being connected and the same effect.

I will appreciate any advice or suggestion, other than buying a new phone :slight_smile:

Miguel.


#7

I’d suggest making sure there are no other apps running in the background, or maybe other Bluetooth connected devices running at the same time. If I have Whatsapp in the background the Ikawa app stutters.


#8

Thanks for the advice deven.patel411, unfortunately it didn’t work, I unpaired other devices and killed all other applications and still same effect.

I also updated my phone’s software to the latest version but still same effect, the moment I tried to load external profiles, the app crashes.

Does anyone else have some other advice?

Miguel.


#9

I decided to re-write my previous reply, as it was all over the place:

Unfortunately my app has gone from bad to worse with crashes. Initially it was fairly stable, but eventually I put the crashes down to having a huge ‘library’ of profiles that I had created. Not having an easy means to organise/file/archive profiles, I just left them to heap up. The app started to become more unreliable and unstable.

As of now I can only seem to create one new profile at a time before the app crashes. If I try to create more, as soon as I try to ‘save’ that action crashes the app immediately. Restarting the app is fine & usable, I can see the newly created profile in the list, but upon attempting to open it, causes immediate app crash.

I decided to go through 108 profiles to manually ‘share’ each one and email it to myself for backup purposes. However there was an intermittent & unpredictable issue with this too; Every so often completing the profile share would also crash the app. This was sometimes happening after the 4th share, or as soon as the 1st! It was a long and tedious task.

Once backed up - I uninstalled the app and started again. Unfortunately this did not remedy the problem either. I’ve tried to uninstall and reinstall numerous times, even shutting down the phone between every step. No Joy.

At present in my app I only have the preloads plus three of my own profiles. One was loaded from my backups, the other is a new profile adapted from that. Those work fine. The third is another loaded from my backups, but upon adding the 3rd profile it crashed the app. I can re-open the app and see the 3rd profile, but trying to open it will cause a crash. If I fresh reinstall & I only have the preloads, then add the same (3rd) profile again, it loads up, views fine & it works! I have found this is fairly consistent behaviour; so I can now only create one new profile of my own, at one time. Each time I want to go beyond this I must go through the faff of uninstalling and reinstalling.

It did cross my mind I may have a phone internal memory issue, but I cleared a few GB off just to be sure and it didn’t make a bit of difference.

All other apps on my phone are stable.

I am starting to wonder if there is a corrupted file floating around my phone’s filesystem, which is not being removed at the point of uninstall. Therefore perhaps the only way to regain previous app performance may be to completely backup and reinstall my entire phone OS, which I am not really prepared to do. So I am just living with the instability, backup/sharing each new profile & reinstalling often!

Android 7.1.1 Sony Xperia Z5


#10

I spent some time this morning trying to figure out a solution. Then I thought about what I did when I first received the roaster & installed the app; I modified a preloaded profile, before I tried to add anything external into the library via a share etc.

Miguel, try uninstalling the app. Reinstall it and choose one of the preloaded profiles. Edit the profile and save it with a new name.

I was then able to keep saving further profiles without a crash! Then I tried to add some of my existing backup profiles by sharing it with myself.

It may not work for everyone & this may be too soon to declare this a success, but so far, so good.

I shall keep you all posted.


#11

Hey another thought accrued to me (maybe unrelated) but has anyone else synched the app and website? Maybe that’s why I haven’t had any problems, I don’t know really.

On side note, I was speaking to a very helpful Nadia via chat on the Ikawa website on another issue and she said they were aware and are looking into your issue. But I am glad you found a resolution.


#12

I must say Ikawa are very, very good with customer service. I have been ever so impressed. I was thinking I ought to contact them, rather than post problems here, but then I realised I wasn’t alone, I thought I would share my experiences in a hope that we can come to a resolve.

I’ll just pop Ikawa an email now, let them know they can contact me if they/the devs need to ask any further specifics.

I looked at this, I thought I was at least signed in. It turns out however I am not. I suppose this must have happened at some point when I was uninstalling the app.

I can’t imagine sign in would be mandatory for everything to work, though I could be wrong!


#13

Forgot to say thanks for letting us all know about that. It was because of your post that I decided to contact Ikawa myself. I said i’d made a post here but if I can be off assistance with answering questions, then I am happy to help.

I got an email from someone at Ikawa called Brad, he asked me to detail my exact issues. I gave him the information I had posted here, along with my ‘fix’ and he said that it had “massively helpful”.

So fingers crossed it’s a simple little bug somewhere. Sometimes if one can supply as much detail as possible, it’s enough for devs to try and replicate the issue and work out where the bug resides.

Just to reiterate, if there is anyone else reading this with crashing issues, perhaps give Ikawa an email too. Try to give as much detail as possible, leading up to causing a crash. The more info they have, the better equipped to deal /quicker a fix will be offered.

If I hear anything further, i’ll be sure to follow up here.

All the best.


#14

I tried your suggestions but still the same.

I got an email from Ikawa saying they are looking into it, hopefully they will have a solution soon.

Thanks a lot to you all, I appreciate the help.

Miguel.


#15

Hi all - happy to report a fix. See my post here:


#16

Sorry to be the one that keeps raising this issue, but I still don’t see any updates available for Android within the Play store. Anyone else?

I have definitely isolated the app bug to be consistent with connecting to the roaster. So after a fresh app install, as soon as a bluetooth connection is established with the roaster this somehow causes the app to run buggy (even after disconnection) thereafter. Problems also coincide with my roaster being returned to base for a service. Maybe this issue isn’t consistent with many, if my roaster had some updated firmware installed :thinking:

Anyway as a result the app is still highly unstable/unusable for me, as I have to constantly share(backup) profiles and start again. It’s frustrating but glad to hear of a fix in the pipeline. Don’t suppose someone could give things a push, please?


#17

I soon found out my ‘fix’ was not to be a fix at all. It wasn’t to be a conclusive end to the unstable app issue. I am more inclined to think that newer roasters may have an alternative firmware installed which is causing a problem within the app. Providing of course, you have recently (within the last few months) acquired your roaster!

Hold tight for the update hitting all good app stores soon!


#18

Yes, let’s hope for that update coming soon.

I was told it would be ready before the end of the year but it isn’t there yet for Android, hopefully in the coming days.

I got my roaster on October 2018 so perhaps it is with the new firmware.

Miguel.


#19

I must stress my theory is highly hypothetical, but roaster firmware seems to make the most sense to me now, even if not verified by HQ.

I do feel your pain @maglez, but I suppose the Play store is the only obstacle getting in our way. Perhaps the release got delayed what with being so close to Christmas.

Are you at least able to get some limited usage with the app/roasting coffee? I would definitely suggest:
-turning off the power to the roaster first.
-uninstalling/ fresh reinstalling the app.
-Import, amend, create profiles PRIOR to establishing a connection with the roaster.
-Repeat the cycle when the app becomes unstable, making sure to share (backup) profiles before uninstall.

Let me know how you get on with that.
All the best.


#20

Have you tried selecting the “update roaster” in the settings and reinstall the update? I asked via email and that was the recommendation.


#21

Hello @deven.patel411 happy new year!

I don’t seem to have the “settings” option in my Android app, let alone the “update roaster” option. Are you on iOS?

I have been in contact with Ikawa about my issues too. The only resolve I have been offered is the app update. The delay (I am told) is with the Google Play Store featuring the update. I was given this info last month, on the 10th, with anticipation of the update being live by 17th - 18th.

I put the blame squarely on Google, they need a kick! :wink: