Can’t Connect to Roaster


#1

Now it’s happened…I don’t know if this is related to the iOS 13 issue that someone posted or not, but I can’t connect to my roaster. It was working for about 2 weeks since I got this roaster.

I tried

  • turning the roaster off for at least 30 minutes and turning it on again, or turning it on/off multiple times
  • deleting the iOS app and reinstalling it again. I even signed up using a new email account and that didn’t work either.
  • restarting my iPhone
  • installing the iOS app on an iPad Pro and an IPad Air 2(slightly older operating system) - these didn’t work.
  • the Ikawa app simply indicates “Looking for roaster…” and nothing happens. If I turn off/on the Bluetooth signal on the iPhone, the app will then indicate “Connecting” but it never connects.
  • I can see the roaster info details (Bluetooth name, roaster ID, type, etc…) in the Ikawa system settings when I turn the Bluetooth off and then on again.
  • I also tried to enable “update roaster firmware” and when the pop-up screen for the Firmware Update (asking whether you want to update Later or Update Now), the app freezes and becomes unresponsive and nothing happens.
  • If I try to run the roaster (which should have the last profile that I ran in memory), the temperature doesn’t increase. It seems to just be the cooling fan and then it stops.

I was creating new profiles on the app when this whole thing started. I don’t know whether the roaster is in some sort of failed firmware update. Is there a way to factory reset the roaster?

Any other tips on how I might troubleshoot this? I’ve already emailed support but since it’s the weekend, I won’t hear back until Monday hopefully.

Thanks and Regards,
Jonah


#2

Hi, I dont really have any more tips. I´m also having issues connecting but I can always get it to work. Usually I start up the roaster and then the ikawa-app. No connection. Then I disable BT on my iPhone and enable it again after 10 seconds and then usually I can connect to the roaster. Sometime I have to do it a couple of times though.
Pre iOS 13 I never had any issues so I think Ikawa has a potential problem at hand here that needs fixing.

I really hope Ikawa will fix it for you asap. I can´t stand being without my roaster so I feel your pain!


#3

Have you heard back from Ikawa support?


#4

They had to replace the roaster as they concluded that it was a hardware issue rather than software. It just wouldn’t connect even with older versions of the IOS. With the new roaster, I still have to turn Bluetooth off/on every time, but at least it works.


#5

If already done please ignore: Try opening your bluetooth settings (on phone) and search for available devices while the roaster is on. I think it is the security setting on the phone, or bluetooth firmware on the phone, possibly.


#6

FWIW: The time it took for the APP to recognise the roaster took an unusual long time at my last two sessions (both after I upgraded to iOS13). Once established, I had no further problems during the session of multiple roasts.


#7

I´m having the same issues every time when connecting to roaster. BT off and on again and sometimes I have to turn roaster off and on again as well. I hope they sort it out soon.


#8

the bluetooth connection issue I had was when I tried connecting in winter when the Ikawa home roaster was stored in my cold utility room, and it failed to connect until I took the roaster into a warmer room to warm through, then it connected!


#9

I’m having this BT connection issue recently. And I can feel the tendency of getting worse. It all began after my iPhone X was upgraded to ios13. It sounds like exactly the case everyone else is encountering, I know.

But has anyone noticed the difference on Bluetooth setting on the phone’s end before and after connected? There’s no device (IKAWA home roaster) showing on the Bluetooth list while the roaster is “looking for” it, yet its name will be there after connected to the phone.

Here’s the snapshot. I wonder what was happening on both ends while the phone is looking for connectable device.


#10

I had connection issues with iPhone7, iPhone8 and iPad. Devices connected randomly, I could not find any pattern. Than I tried one thing: log off Ikawa app and log on again. I x-checked this on all devices and it worked. If I turn off my roaster (and stay logged on Ikawa app) and turn roaster back on I cannot get connection with Ikawa app. I have to log off and log on again. Than connection is immediate.


#11

While I did have recurring connection problems for the initial pairing for a while, this seems to have disappeared recently.

I’m running iPhone 8 and iPad Air2, iOS13.3, App 20.226