Fan issue after firmware update


#1

Hi,

After updating the firmware today, the roaster does not drop the beans at the end of the roasting.
I have tried 2 different beans/profiles with the same results. I am not sure but the beans seem to have more chaff than usual. The device is placed on the counter top with a lot off space around and on top.
Has anyone experienced this?


#2

Are they new beans? And new profile? That part was unclear. What was your moisture loss for the batches? Did the fan sound like it usually does when it drop the beans?


Not dumping beans
#3

No they are not new beans,I have been roasting with the same beans before. The profile I used is kochere Debo. I didn’t notice anything particular with the fan. I used 50gr and got out 44gr.


#4

I’m confused. The Android update hasn’t become available yet so I’m still “as we were”, but I thought that this was an App update.
Is it also a firmware update?


#5

I am using the iPhone app. I received yesterday a notification to install a new firmware V23. I found some info here but it seems to be for ikawa pro.


#6

I don’t have any other ideas about the fan. But looking at my app setting, I definitely have the #3 Time Calibration option. I have an Ethiopian I’ll be “recalibrating” with to see how everything (including the 6th) effect the roasting.


#7

Just to share with you, I received an email from the support team. This is a know issue and an update should be available soon.


#8

Ok great! I was just about to post that my drop fan was sounding a little weird too.


#9

I too updated my firmware, and now the IKAWA roaster is useless. The roaster blows about 25% of the beans out of roasting chamber, leaving the rest in the machine. I know of no way to adjust the blow-out settings. Instead, I had to remove the lid and tip the entire roaster over to get the beans out.
As with dimitri, I a using the same beans and roast profile that I used for previous roasts on the older firmware, and the machine worked fine then.
IKAWA! Can you sent out another firmware update NOW?


#10

Deven and Dimitri, have either of you found a way to correct this? I wrote to IKAWA support and was sent some steps that were to correct the problem, but it did not help. I still have to pick up the whole roaster and dump the beans out!


#11

Mine doesn’t have a problem getting the beans out but does sound weird/different. It does not sound like a smooth increase in fan but kind of jumps up in steps.


#12

FirmwareGate!
Mine seems to hesitate, then blows maybe 30% of the beans out, but then stops leaving the rest in the roaster. Before I updated the firmware, it ran the fan at top speed longer, extracting all the beans and continuing to blow for a second or so.


#13

I didn’t had the time to try yet. I let you know as soon as I can.


#14

It occurred once with my machine that about 80 percent of the roasted beans were left in the chamber. The other times, the fans sound like pause or hesitate if you like, and then it goes full speed. Not an inconvenient issue, but did sound irritating and worrying to me.


#15

Where is the promised bug fix? I am still using a spoon to get the beans out after each roast.


#16

Bean extraction problem solved!

On the advice of Ikawa, I updated my firmware again (several times) and my roaster is now extracting the roasted beans entirely. Below are the steps they recommended, but note that you must have your Ikawa roaster on and communicating with your device.

From Ikawa Support:
If you enter ‘settings’ in the app, you should be able to flick the option for ‘upgrade firmware’ across.
Head back to the main menu of your device, before entering back into the app. There will be a prompt asking you if you wish to update your firmware. Select ‘update’ and you will see a red screen appear. This screen will firstly update your firmware, before also updating your settings. If this is successful, you will see a pop-up stating ‘Roaster Update Complete’.


#17

I confirm also it’s solved.


#18

I reject all submissions of the fan issue being “solved”. I’ve committed over 1000 grams of green beans and another fan test “experiment” and I am here to tell you that this issue has not been “solved”. I submit to these people of this order; Submission “A”: roasting an Ethiopian wet process came out terrible on all previous WP Ethiopian profiles I have. Submission “B”: running the same fan test, not only did the end temp come consistently and repeatedly lower, but also took longer to reach a final and steady temperature.

In conclusion, I submit to you hot air ladies and hot air gentlemen of these proceedings that this issue has not been resolved. I call for the high clerk to address said issues and let us know “what’s up”.


#19

Just to prove to you @deven.patel411 , I don’t only appear when I have a problem :stuck_out_tongue_closed_eyes:

This sounds very similar to an issue I had with existing profiles, after I sent my roaster in for a service. I do believe the soft foam seal (which the glass lid sits on), had been replaced, so this may not be entirely related. However I also believe the roaster had new firmware installed, which explains why I have had Android app crash issues ever since!

This of course is all highly speculative, but one thing I could confidently report, was that my existing profile roasts where coming out lighter. I could tell, because I had been roasting a particular batch of greens, on the very same profile before and after the service. I was able to record a drop in % of roasting that I initially put down to a more efficient air flow/ beans moving more (due to the improved, tighter foam seal).

I tried to tweak the fan to reduce it’s speed, but eventually the beans were moving too slowly. I soon realised all existing profile points required approx. 5c temp raise to reach a similar % of roasting, that I was reaching before.

So to conclude I possibly think the new firmware has introduced changes. Perhaps calibration of the temp sensor, though I would have thought that calibration would be independent on each machine. In any case I certainly observed a change in my machine.

Ultimately your issue sounds the same as mine, which could be the result of the same thing.


#20

Point taken lol

I did not notice any foam issues. All my roasts are coming out bitter. Which makes me think (nerd alert) the heat transference coefficient has been altered. I’m not sure how the fan rate and coil energy has been altered. But my ET thermometer is reading a 25 degree difference, and if I raise the app by 25 degrees, it finishes at the ET temp I have been accustomed to seeing. Now what’s really odd is that on the ramp up. The ET reaches a lower temp but then takes more time to pass through the remaining 25F to reach the final temp. I am not sure if this is a hardware or software issue but altering my profiles accordingly has made it clear that I have not “mastered” roasting yet.