Not dumping beans


#1

Beans roasting ok but not dumping unless I tilt the toaster forward, never been a problem before now.


#2

Hello @michaelredmond.

Interesting. I assume this is related to the recent Ikawa Home app update that recently hit the Google Play store for Android devices? (I am under the assumption you are running Android as opposed to iOS?)

I make the assumption based on the fact that iOS have already been dealt an update and this issue has already been raised on a similar thread

In any case I have recently updated my Android app with the aforementioned recent release, but I am yet to fully test it. I have however, noticed my app crash issue (when opening certain profiles) has now stopped. I just hope this problem hasn’t been exchanged for beans not dumping.

I’ll be roasting in the next couple of days so i’ll know for sure how the app is running after that. Will keep you posted.


#3

Iphone5 here, before the update I had no problems, problems after update. I emailed Ikawa (Brad where you at!?!?), a couple days later I got a new update and everything seems back to normal. I did a couple roasts and things (timings, sounds) all seem to be set back right and the coffee tastes much better. I’ll run another temp/fan test run and try and post the results again.

Tldr: email Ikawa, they will grant you all your wishes…but I’m still waiting on my goose.


#4

I agree with @deven.patel411, contact Ikawa. Brad is usually pretty good at getting back to any queries quite quickly.

Although I should suggest you attempt to follow the steps in the other post, regarding updating the roaster firmware.

It just might be the case that you’ve updated the app, but the roaster is still running on old firmware. Within the NEW app, one needs to manually select the option to update roaster firmware. It won’t do update automatically. So it might well be worth your while trying that suggestion out from within the menu > settings.

Do please update us if you do manage to successfully resolve your issue. The chances are you are not alone and any contributions here in this dedicated public forum, might just help someone else out.

Goodluck.


#5

Hi Christo,
I’m using an iPhone X, I had problems with the firmware update and also updating the app, emailed Brad a few times and spoke to him on the Phone and he gave me plenty of help and the problem seems to have been resolved. Just roasting my second lot and so far so good.


#6

What I did next, I updated the firmware and tried to roast but no drop, updated the app and re did the firmware and the same, deleted the app and did it all again and zilch. Turned off my machine for an hour and re did the firmware and app and as I’m writing this it’s dropped fully so bingo alls well in my kitchen.


#7

Ahh thats great that you got it all fixed now! What’s interesting is that over on the other forum thread, similar results too; after a few attempts of re-installing app/firmware, something finally worked out.

What I will personally take from all this is that perhaps power down of the roaster was key. Maybe the roaster required a power cycle to ‘boot up’ on the update.

Cheers, happy roasting!


#8

I wasn’t aware that the Android update was available. I thought it would auto update like other apps. I see now that it is on the Play store.

I have reservations about updating because everything is working fine now.

Does the updated app work without the firmware upgrade or do they go hand in hand?

The update process seems to be, update app, switch on roaster, apply new firmware, shut app down, power down roaster then restart?

Anyone know what the firmware update is for?


#9

The app auto updated so I had no option but to try it. Failed. App kept crashing and didn’t update firmware and became almost unusable.

The solution suggested by support was to uninstall the app then reinstall. Down side is that all my profiles bar those I had backed up and the one on the roaster are gone.

Do any Android users know how to get backups saved to Google drive back onto the App?

There is a restore option under the “Account” bar which should give a list of dates. Only one date is showing from my last roast this morning and it doesn’t have my previous profiles.

Guess I could try and paste them here and try to link to the app? Yes that works.

What an absolute PITA. Lots of my best profiles gone. Should have been better with backups…


#10

Mine was working ok last week then suddenly I had to update this and that and yes it’s a PITA, I dislike the fact that more and more my life has to have technology to function.


#11

Would “like” your post. But I’m struggling to find anything to like about this update. Hopefully it will work from here on.


#12

Yea, I also did not have the option to update this time around which was a bit concerning. Though it did resolve my issue so…more of an existential/philosophical question of intent vs free will, though I have no doubt the people working on these issues have the best of intentions.

It would be nice to be able to revert back to a previous version of software in the case where an update does not work as it was intended.

So we can test the update. Is that the best option? I am not sure, what if the update was supposed to save humanity and then time traveling humans say we destroyed the world…maybe I’ve been watching too much Future Man on Hulu. But we’ll see.

I also would have said that you can restore from the settings menu, but that made me think. How and when do we decide when to create a restore point? So far I do not know. This is not my area of “nerd-dom” so I’d be interested to hear from someone who knows.

I’m sure you have a general layout of your favorite profiles but I definitely know that feeling when you loose them. My condolences for your loss.


#13

The backup feature is supposed to be automatic with a new list created each time you use the roaster. You should see a list of dates under the “Account” sub menu when you select restore. So a restore point is taken every time you use it.

I think that it only works if you are logged in via “Account” when using the app. I think it is a one time only login. My problem I think was that I was never aware of it and had never logged into the app since day one therefore no backups were ever created.

No doubt I’ll manage to recreate the profiles easily enough. Thank goodness for paper notes!

Hopefully future upgrades will learn lessons from this as it seems to have caused many users issues. I haven’t done a roast with the new firmware yet so can’t be sure I’m out of the woods yet.