Unable to download an experimental roaster profile from the hot air community


#1

Hi all,

I am having difficulty downloading a test roast profile from a thread at Experimental Approach to Roasting .

The recipe I want is loaded at https://share.ikawa.support/profile_home/?CAESEJEF1NW7JUIgijEC17tOj8MaCEJhc2VsaW5lIgUIABD0AyIGCLECEN4LIgYIxw4QvA8iBgjRIxCwEyIGCMQsEMQTKgUIABDZASoGCMQsEJkBMAE6BgjGNBC2AUImChxibHhtMDBDZXR4Z1NmTVNUNDRpdklyS1AwU1YyEgAaACIAKAA=

I have the ikawa home app on my tablet; I fired it up (incidentally, having successfully downloaded and installed the latest firmware upgrade from Ikawa earlier today) and went to the at home hot air community. I found the post with the recipe I wanted and clicked on it. I was directed to a big red oval inviting me to tap to open the roast recipe in the Ikawa home app, which I did. After a longish pause the screen displayed this message: ‘Whoops - looks like you don’t have the Ikawa Home app needed to view this’ and inviting to download the app etc etc. That app was, of, course happily running away in the background on my tablet, but it obviously couldn’t be seen by the downloading software.

Does anybody know what’s gone wrong? Fwiw I am running the app on a samsung galaxy, and viewing the blog through a browser on the same machine.

Regards,
Alan B.


#2

Hey Alan,

Try this, is my baseline from the latest version of the app:

‘Baseline’ freshly roasted by @ikawahome, here’s the recipe
https://share.ikawa.support/profile_home/?CAESEJEF1NW7JUIgijEC17tOj8MaCEJhc2VsaW5lIgUIABD0AyIGCLECEN4LIgYIxw4QvA8iBgjRIxCwEyIGCMQsEMQTKgUIABDZASoGCMQsEJkBMAE6BgjGNBC2AUImChxibHhtMDBDZXR4Z1NmTVNUNDRpdklyS1AwU1YyEgAaACIAKAA=

Hope it helps.

Steve


#3

Hi Steve,
Thanks for the assistance but it’s still not downloading your recipe. After clicking your link it gets as far as the large red oval telling me to click it, but when I do so it just reverts to the ‘whoops’ page telling me i don’t have the app. Which is odd, because I have the app running in the background (I also tried switching the app off in case that was the problem. It wasn’t)


#4

Try deleting the app and reinstalling, then make sure the “update roaster firmware” is selected in settings and allow the firmware update to redownload.


#5

Hi deven.patel411,
Well, it sounded a bit drastic, but easier on an android than a pc I suppose, so I went ahead and did it. I’ve now got the home app up and running again, with the latest firmware (and configured for auto update).
Unfortunately the symptom still persists: whatever is happening at Ikawa’s send to send me the profile is not able to detect the presence of the app on my machine. Yet it did so earlier today when I updated the firmware.


#6

Hmmm, well I’m a little confused, are you on the galaxy or PC? I am not on a PC I am using my iphone. Is the Ikawa roaster under a trusted/known device on your galaxy? Does the roaster connect to your phone? If so does the roaster information load under the app settings?

I ask because I am wondering if it is a app to roaster problem or just the app just the issue for you.

On a side note have you linked your app sync and profile together on the Ikawa website?

I do not know if the issues are related and I am not an IT expert or anything, just tryin to help.


#7

It’s nice to have ideas coming for me try out, so keep them coming!

I only mentioned a pc because I’ve had some de-installations go very wrong on a pc in the past, and I suspected it would go rather easier on a tablet. As it so proved: I deinstalled and reinstalled the ikawa app on the galaxy tablet (an android device) with no problem.

I don’t appear to have any capability of designating any app or device as trusted on this galaxy.

When upgrading the firmware on the roaster, the whole update ran automatically and trouble free: after reinstalling the app on the tablet, I switched the roaster on. As soon as a blue tooth link was made, the system told me the roaster needed an upgrade, and to click on the notification. When I did so, the software downloaded smoothly to the app on the tablet, and from there to the roaster to finish the job. So on that occasion, Ikawa ‘knew’ where my app was and that it was running.
But when I click on another link, for the new roast profile, it can’t see the app running on my tablet and generates an auto response telling me to d/l and install it on the tablet.

I don’t think this is an app to roaster problem: all apps, old or new, sit on the controlling machine within the app until called on via the blue tooth link. For instance, I note that the new upgrade somes with another dozen or so new profiles that I haven’t tried yet.

There must be some incompatibility, eg between whatever app d/ls the profile, and the app as running on an android.


#8

When I click a link, it opens a new tab in my internet browser with a dialogue box that asks; “open this page in ‘ikawa home’?” With options to open/cancel.

Yea it seems the problem might be related to a communication problem between the link accessing your Home app on the Galaxy.

I don’t have any more ideas but I hope you get your issue resolved soon.


#9

How about a brute force approach. Here are the data points, so you could just create a new profile:

Time. Temp ©
0.30. 150c
3.06. 198c
7.36. 248c
9.30. 250c

Fan

0.00. 85%
9.30. 60%
11.12. 72%

Hope that helps :slight_smile:


#10

Hi: many thanks for this data. However, Ikawa have very kindly got back to me with a solution: change the browser! I did, it worked, and I now have your profile in my app. I’m not due to roast for a week or so but I’ll be using your app when I do - I hope to be able to home in on a point shortly after halfway through first crack.
Best regards to one and all for the help.

Alan B.


#11

No problem. I usually hope that first crack happens at the 7.36 mark. If not I try raising the temp until it does, and then take it from there. Will definitely be interested to hear how you get on.


#12

Hi Alan,

I struggled with this problem for a while and found a different solution. I use Firefox as my browser on an Android phone and I get the same error message as you if I click on a profile hyperlink. The solution for me was this:

  1. Long press on the hyperlink included in the forum (before going through to the page with the red oval)
  2. Menu pops up with various sharing/copying options
  3. Select ‘Open With IKAWA Home App’

I realise you already have a workaround but I thought I’d mention it just in case you wanted to keep using your previous browser.

Alex


#13

Thanks Alex - it’s worth bearing in mind, although I don’t intend to d/l any more profiles until I’ve experimented with this basic one.

Cheers,
Alan.